Атрибут ESPEncryptionAlg
Атрибут ESPEncryptionAlg
Атрибут ESPEncryptionAlg задает использование протокола ESP с преобразованием любым из указанных алгоритмов шифрования.
| Внимание! | Алгоритм ГОСТ Р 34.12-2015 «Кузнечик» в режиме MGM без шифрования не обеспечивает защиту конфиденциальности и должен применяться только для имитозащиты трафика. Варианты обозначений: • в cisco-like консоли - esp-kuznyechik-mgm-mac; • в LSP - ENCR_KUZNYECHIK_MGM_MAC_KTREE (в атрибуте ESPEncryptionAlg структуры IPsecProposal2) и GR341215K-K352-MGM_MAC-34 (в атрибуте CipherAlg структуры ESPTransform); • в ГСУ - ESP ENCR_KUZNYECHIK_MGM_MAC_KTREE. Если для защиты трафика выбран только этот алгоритм, то пользовательские данные будут отправлены в канал связи незашифрованными, в формате, позволяющем обеспечить контроль их целостности. |
| Внимание! | Алгоритм ГОСТ Р 34.12-2015 «Магма» в режиме MGM без шифрования не обеспечивает защиту конфиденциальности и должен применяться только для имитозащиты трафика. Варианты обозначений: • в cisco-like консоли - esp-magma-mgm-mac; • в LSP - ENCR_MAGMA_MGM_MAC_KTREE (в атрибуте ESPEncryptionAlg структуры IPsecProposal2) и GR341215M-K288-MGM_MAC-35 (в атрибуте CipherAlg структуры ESPTransform); • в ГСУ - ESP ENCR_MAGMA_MGM_MAC_KTREE. Если для защиты трафика выбран только этот алгоритм, то пользовательские данные будут отправлены в канал связи незашифрованными, в формате, позволяющем обеспечить контроль их целостности. |
| Синтаксис | ESPEncryptionAlg = ENCR_NULL | ENCR_3DES | ENCR_AES_CBC_128 | ENCR_AES_CBC_192 | ENCR_AES_CBC_256 | ENCR_KUZNYECHIK_MGM_KTREE | ENCR_MAGMA_MGM_KTREE | ENCR_KUZNYECHIK_MGM_MAC_KTREE | ENCR_MAGMA_MGM_MAC_KTREE |
| Значение | cписок допустимых алгоритмов: • ENCR_NULL – NULL Encryption согласно RFC 2410; • ENCR_3DES – 3DES CBC-Mode Cipher согласно RFC 2451; • ENCR_AES_CBC_128 – AES-CBC Cipher с длиной ключа 128 бит согласно RFC 3602; • ENCR_AES_CBC_192 – AES-CBC Cipher с длиной ключа 192 бит согласно RFC 3602; • ENCR_AES_CBC_256 – AES-CBC Cipher с длиной ключа 256 бит согласно RFC 3602; • ENCR_KUZNYECHIK_MGM_KTREE – ГОСТ Р 34.12-2015 «Кузнечик» в режиме MGM; • ENCR_MAGMA_MGM_KTREE – ГОСТ Р 34.12-2015 «Магма» в режиме MGM; • ENCR_KUZNYECHIK_MGM_MAC_KTREE – ГОСТ Р 34.12-2015 «Кузнечик» в режиме MGM без шифрования; • ENCR_MAGMA_MGM_MAC_KTREE – ГОСТ Р 34.12-2015 «Магма» в режиме MGM без шифрования. Допускается указывать либо только AEAD-алгоритмы, либо только не AEAD-алгоритмы. Алгоритмы в режиме MGM являются AEAD алгоритмами. |
| Значение по умолчанию | Атрибут является обязательным |